@sanity/ui 4.2.7

@sanity/ui@4.2.7 was published on 2026-09-26. Its manifest declares 10 runtime dependencies and 3 peer requirements. Type declarations are bundled according to the package metadata. The declared Node.js requirement is >=22.12.

Deprecated: Class names collide with @sanity/ui 4.4.4 (shipped in sanity@6.19.0) when both load on one page, breaking styles. Upgrade to @sanity/ui@^4.4.4.

All @sanity/ui versions · Permanent reference to 4.2.7 · Latest release

Package specifications

Version4.2.7
License declarationMIT
Published2026-09-26T20:57:08.005Z
Node.js requirement>=22.12
Type declarationsBundled declarations
Runtime dependency count10
Peer requirement count3
Optional dependency count0
Minified sizeMeasurement not available yet
Minified + gzipMeasurement not available yet
Unpacked distribution size1566.05 KiB
Published file count100
Package typemodule
ES module entryNot declared
Default entryNot declared
Side effects declaration["*.css"]
Direct advisoriesUnknown
Resolved graph dependenciesUnknown
Repository starsUnknown
Repository forksUnknown

Install @sanity/ui 4.2.7

npm install @sanity/ui@4.2.7
pnpm add @sanity/ui@4.2.7
yarn add @sanity/ui@4.2.7

Runtime dependencies

Peer requirements

Optional dependencies

  • None declared

How to interpret the specifications

Bundlephobia measurements use its standard package build and may exclude peer dependencies. Unpacked npm distribution size includes shipped files and is a different measurement. Module declarations do not prove tree-shaking or runtime compatibility.

Advisories apply to this package version directly; transitive dependencies need separate inspection. Repository signals describe the whole repository and are current observations, including on historical-version pages.

Evidence and freshness