level-party 5.0.0
Open a leveldb handle multiple times
level-party@5.0.0 was published on 2021-03-07. Its manifest declares 3 runtime dependencies and 0 peer requirements. Bundled type declarations are not declared in the inspected metadata. The declared Node.js requirement is >=10.
Deprecated: Superseded by rave-level (https://github.com/Level/community#faq)
All level-party versions · Permanent reference to 5.0.0 · Latest release
Package specifications
| Version | 5.0.0 |
|---|---|
| License declaration | MIT |
| Published | 2021-03-07T10:00:24.933Z |
| Node.js requirement | >=10 |
| Type declarations | Not declared |
| Runtime dependency count | 3 |
| Peer requirement count | 0 |
| Optional dependency count | 0 |
| Minified size | Measurement not available yet |
| Minified + gzip | Measurement not available yet |
| Unpacked distribution size | 23.07 KiB |
| Published file count | 15 |
| Package type | Not declared |
| ES module entry | Not declared |
| Default entry | index.js |
| Side effects declaration | Not declared |
| Direct advisories | 0 |
| Resolved graph dependencies | 42 |
| Repository stars | 146 |
| Repository forks | 11 |
Install level-party 5.0.0
npm install level-party@5.0.0 pnpm add level-party@5.0.0 yarn add level-party@5.0.0
Runtime dependencies
- level ^6.0.0
- multileveldown ^3.0.0
- readable-stream ^3.6.0
Peer requirements
- None declared
Optional dependencies
- None declared
Resolved dependency graph
This deps.dev graph describes a generic 64-bit Linux environment, not your application lockfile.
- abstract-leveldown@6.2.3 — indirect
- b4a@1.9.0 — indirect
- base64-js@1.5.1 — indirect
- buffer@5.7.1 — indirect
- deferred-leveldown@5.3.0 — indirect
- duplexify@4.1.3 — indirect
- encoding-down@6.3.0 — indirect
- end-of-stream@1.4.5 — indirect
- errno@0.1.8 — indirect
- ieee754@1.2.1 — indirect
- immediate@3.3.0 — indirect
- inherits@2.0.4 — indirect
- length-prefixed-stream@2.0.0 — indirect
- level@6.0.1 — direct
- level-codec@9.0.2 — indirect
- level-concat-iterator@2.0.1 — indirect
- level-errors@2.0.1 — indirect
- level-iterator-stream@4.0.2 — indirect
- level-js@5.0.2 — indirect
- level-packager@5.1.1 — indirect
- level-supports@1.0.1 — indirect
- leveldown@5.6.0 — indirect
- levelup@4.4.0 — indirect
- ltgt@2.2.1 — indirect
- multileveldown@3.0.0 — direct
- napi-macros@2.0.0 — indirect
- node-gyp-build@4.1.1 — indirect
- numeric-id-map@1.1.0 — indirect
- once@1.4.0 — indirect
- protocol-buffers-encodings@1.2.0 — indirect
- prr@1.0.1 — indirect
- reachdown@1.1.0 — indirect
- readable-stream@3.6.2 — direct
- safe-buffer@5.2.1 — indirect
- signed-varint@2.0.1 — indirect
- stream-shift@1.0.3 — indirect
- string_decoder@1.3.0 — indirect
- util-deprecate@1.0.2 — indirect
- varint@5.0.0 — indirect
- varint@5.0.2 — indirect
- wrappy@1.0.2 — indirect
- xtend@4.0.2 — indirect
How to interpret the specifications
Bundlephobia measurements use its standard package build and may exclude peer dependencies. Unpacked npm distribution size includes shipped files and is a different measurement. Module declarations do not prove tree-shaking or runtime compatibility.
Advisories apply to this package version directly; transitive dependencies need separate inspection. Repository signals describe the whole repository and are current observations, including on historical-version pages.
OpenSSF repository checks
Provider assessment: 2026-08-24T00:00:00Z. These are repository checks, not a jsL maintenance score.
| Dangerous-Workflow | 10/10 — no dangerous workflow patterns detected |
|---|---|
| Maintained | 0/10 — project is archived |
| Binary-Artifacts | 10/10 — no binaries found in the repo |
| Code-Review | 0/10 — Found 2/22 approved changesets -- score normalized to 0 |
| Pinned-Dependencies | 0/10 — dependency not pinned by hash detected -- score normalized to 0 |
| Token-Permissions | 0/10 — detected GitHub workflow tokens with excessive permissions |
| CII-Best-Practices | 0/10 — no effort to earn an OpenSSF best practices badge detected |
| Fuzzing | 0/10 — project is not fuzzed |
| License | 10/10 — license file detected |
| Branch-Protection | 0/10 — branch protection not enabled on development/release branches |
| Security-Policy | 0/10 — security policy file not detected |
| SAST | 0/10 — SAST tool is not run on all commits -- score normalized to 0 |
Evidence and freshness
- https://registry.npmjs.org/level-party/5.0.0 — retrieved 2026-10-30T02:35:41.455Z
- https://api.deps.dev/v3/projects/github.com%2FLevel%2Fparty — retrieved 2026-10-30T00:10:40.827Z
- https://api.deps.dev/v3/systems/npm/packages/level-party/versions/5.0.0 — retrieved 2026-10-30T02:35:41.995Z
- https://api.deps.dev/v3/systems/npm/packages/level-party/versions/5.0.0:dependencies — retrieved 2026-10-30T02:35:42.011Z