multileveldown 2.3.1
multilevel implemented using leveldowns with reconnect support
multileveldown@2.3.1 was published on 2018-01-31. Its manifest declares 7 runtime dependencies and 0 peer requirements. Bundled type declarations are not declared in the inspected metadata. No Node.js engine requirement is declared in this manifest.
Deprecated: Superseded by many-level (https://github.com/Level/community#faq)
All multileveldown versions · Permanent reference to 2.3.1 · Latest release
Package specifications
| Version | 2.3.1 |
|---|---|
| License declaration | MIT |
| Published | 2018-01-31T12:28:45.086Z |
| Node.js requirement | Not declared |
| Type declarations | Not declared |
| Runtime dependency count | 7 |
| Peer requirement count | 0 |
| Optional dependency count | 0 |
| Minified size | Measurement not available yet |
| Minified + gzip | Measurement not available yet |
| Unpacked distribution size | Not supplied |
| Published file count | Not supplied |
| Package type | Not declared |
| ES module entry | Not declared |
| Default entry | index.js |
| Side effects declaration | Not declared |
| Direct advisories | 0 |
| Resolved graph dependencies | 35 |
| Repository stars | 58 |
| Repository forks | 20 |
Install multileveldown 2.3.1
npm install multileveldown@2.3.1 pnpm add multileveldown@2.3.1 yarn add multileveldown@2.3.1
Runtime dependencies
- levelup ^1.3.1
- duplexify ^3.4.2
- end-of-stream ^1.1.0
- numeric-id-map ^1.1.0
- abstract-leveldown ^2.4.1
- length-prefixed-stream ^1.4.0
- protocol-buffers-encodings ^1.1.0
Peer requirements
- None declared
Optional dependencies
- None declared
Resolved dependency graph
This deps.dev graph describes a generic 64-bit Linux environment, not your application lockfile.
- abstract-leveldown@2.6.3 — indirect
- abstract-leveldown@2.7.2 — direct
- b4a@1.9.0 — indirect
- buffer-alloc-unsafe@1.1.0 — indirect
- core-util-is@1.0.3 — indirect
- deferred-leveldown@1.2.2 — indirect
- duplexify@3.7.1 — direct
- end-of-stream@1.4.5 — direct
- errno@0.1.8 — indirect
- inherits@2.0.4 — indirect
- isarray@0.0.1 — indirect
- isarray@1.0.0 — indirect
- length-prefixed-stream@1.6.0 — direct
- level-codec@7.0.1 — indirect
- level-errors@1.0.5 — indirect
- level-iterator-stream@1.3.1 — indirect
- levelup@1.3.9 — direct
- numeric-id-map@1.1.0 — direct
- once@1.4.0 — indirect
- process-nextick-args@2.0.1 — indirect
- protocol-buffers-encodings@1.2.0 — direct
- prr@1.0.1 — indirect
- readable-stream@1.1.14 — indirect
- readable-stream@2.3.8 — indirect
- safe-buffer@5.1.2 — indirect
- semver@5.4.1 — indirect
- signed-varint@2.0.1 — indirect
- stream-shift@1.0.3 — indirect
- string_decoder@0.10.31 — indirect
- string_decoder@1.1.1 — indirect
- util-deprecate@1.0.2 — indirect
- varint@5.0.0 — indirect
- varint@5.0.2 — indirect
- wrappy@1.0.2 — indirect
- xtend@4.0.2 — indirect
How to interpret the specifications
Bundlephobia measurements use its standard package build and may exclude peer dependencies. Unpacked npm distribution size includes shipped files and is a different measurement. Module declarations do not prove tree-shaking or runtime compatibility.
Advisories apply to this package version directly; transitive dependencies need separate inspection. Repository signals describe the whole repository and are current observations, including on historical-version pages.
OpenSSF repository checks
Provider assessment: 2026-08-24T00:00:00Z. These are repository checks, not a jsL maintenance score.
| Dangerous-Workflow | 10/10 — no dangerous workflow patterns detected |
|---|---|
| Maintained | 0/10 — project is archived |
| Code-Review | 1/10 — Found 2/19 approved changesets -- score normalized to 1 |
| Binary-Artifacts | 10/10 — no binaries found in the repo |
| Pinned-Dependencies | 0/10 — dependency not pinned by hash detected -- score normalized to 0 |
| Token-Permissions | 0/10 — detected GitHub workflow tokens with excessive permissions |
| CII-Best-Practices | 0/10 — no effort to earn an OpenSSF best practices badge detected |
| Fuzzing | 0/10 — project is not fuzzed |
| License | 10/10 — license file detected |
| Branch-Protection | 0/10 — branch protection not enabled on development/release branches |
| Security-Policy | 0/10 — security policy file not detected |
| SAST | 0/10 — SAST tool is not run on all commits -- score normalized to 0 |
Evidence and freshness
- https://registry.npmjs.org/multileveldown/2.3.1 — retrieved 2026-10-30T02:37:53.843Z
- https://api.deps.dev/v3/projects/github.com%2FLevel%2Fmultileveldown — retrieved 2026-10-30T00:23:42.627Z
- https://api.deps.dev/v3/systems/npm/packages/multileveldown/versions/2.3.1 — retrieved 2026-10-30T02:37:54.362Z
- https://api.deps.dev/v3/systems/npm/packages/multileveldown/versions/2.3.1:dependencies — retrieved 2026-10-30T02:37:54.359Z