snyk 1.234.0
snyk library and cli utility
snyk@1.234.0 was published on 2019-10-09. Its manifest declares 45 runtime dependencies and 0 peer requirements. Bundled type declarations are not declared in the inspected metadata. The declared Node.js requirement is >=6.
Deprecated: A medium severity vulnerability was found in the Snyk CLI version you are using. We fixed the vulnerability in version 1.996.0. We recommend updating to the latest version. More details here: https://snyk.co/ue1NS
All snyk versions · Permanent reference to 1.234.0 · Latest release
Package specifications
| Version | 1.234.0 |
|---|---|
| License declaration | Apache-2.0 |
| Published | 2019-10-09T11:29:44.050Z |
| Node.js requirement | >=6 |
| Type declarations | Not declared |
| Runtime dependency count | 45 |
| Peer requirement count | 0 |
| Optional dependency count | 0 |
| Minified size | Measurement not available yet |
| Minified + gzip | Measurement not available yet |
| Unpacked distribution size | 6561.52 KiB |
| Published file count | 926 |
| Package type | Not declared |
| ES module entry | Not declared |
| Default entry | dist/lib/index.js |
| Side effects declaration | Not declared |
| Direct advisories | 4 |
| Resolved graph dependencies | Unknown |
| Repository stars | Unknown |
| Repository forks | Unknown |
Install snyk 1.234.0
npm install snyk@1.234.0 pnpm add snyk@1.234.0 yarn add snyk@1.234.0
Runtime dependencies
- opn ^5.5.0
- diff ^4.0.1
- glob ^7.1.3
- uuid ^3.3.2
- chalk ^2.4.2
- debug ^3.1.0
- abbrev ^1.1.1
- lodash ^4.17.14
- needle ^2.2.4
- semver ^6.0.0
- os-name ^3.0.0
- then-fs ^2.0.0
- inquirer ^6.2.2
- tempfile ^2.0.0
- snyk-tree ^1.0.0
- wrap-ansi ^5.1.0
- strip-ansi ^5.2.0
- configstore ^3.1.2
- proxy-agent *
- snyk-config ^2.2.1
- snyk-module 1.9.1
- snyk-policy 1.13.5
- ansi-escapes 3.2.0
- snyk-resolve 1.0.1
- @snyk/gemfile 1.2.0
- git-url-parse 11.1.2
- @types/restify ^4.3.6
- proxy-from-env ^1.0.0
- snyk-go-plugin 1.11.1
- @snyk/dep-graph 1.12.0
- snyk-mvn-plugin 2.4.0
- snyk-php-plugin 1.6.4
- snyk-sbt-plugin 2.8.0
- update-notifier ^2.5.0
- snyk-try-require 1.3.1
- @types/agent-base ^4.2.0
- snyk-nuget-plugin 1.12.1
- snyk-resolve-deps 4.4.0
- snyk-docker-plugin 1.29.1
- snyk-gradle-plugin 3.1.0
- snyk-python-plugin ^1.13.3
- source-map-support ^0.5.11
- @snyk/cli-interface ^2.0.3
- @snyk/snyk-cocoapods-plugin 1.0.3
- snyk-nodejs-lockfile-parser 1.16.0
Peer requirements
- None declared
Optional dependencies
- None declared
How to interpret the specifications
Bundlephobia measurements use its standard package build and may exclude peer dependencies. Unpacked npm distribution size includes shipped files and is a different measurement. Module declarations do not prove tree-shaking or runtime compatibility.
Advisories apply to this package version directly; transitive dependencies need separate inspection. Repository signals describe the whole repository and are current observations, including on historical-version pages.
Known direct advisories
Evidence and freshness
- https://registry.npmjs.org/snyk/1.234.0 — retrieved 2026-10-30T11:51:22.603Z
- https://api.deps.dev/v3/systems/npm/packages/snyk/versions/1.234.0 — retrieved 2026-10-30T11:51:23.231Z